Lucas Workflow Demo: Packages

Lucas Workflow Demo
Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Packages
Packages
Here are the packages with brief descriptions (if available):
\ N LucasWorkflowAssemblies
Generated on Mon Apr 29 2013 23:15:45 for Lucas Workflow Demo by doxygen 1.8.3.1


Lucas Workflow Demo: Package LucasWorkflowAssemblies

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Packages
Classes
Package LucasWorkflowAssemblies

Classes

class | CalculateDateByBusinessDays
This class is used to calculate the date that is X business days from now. More...
class | DoSomething
This class does X, Y and Z More...
class | MyJsonResponse
This class is used for deserializing the JSON response from the endpoint. More...
class | MyJsonRequest
This class is used for serializing the JSON request to the endpoint. More...


Lucas Workflow Demo: Class List

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
\ N LucasWorkflowAssemblies |
o C CalculateDateByBusinessDays | This class is used to calculate the date that is X business days from now.
o C DoSomething | This class does X, Y and Z
o C MyJsonResponse | This class is used for deserializing the JSON response from the endpoint.
\ C MyJsonRequest | This class is used for serializing the JSON request to the endpoint.


Lucas Workflow Demo: LucasWorkflowAssemblies.CalculateDateByBusinessDays Class Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • CalculateDateByBusinessDays
Protected Member Functions | Properties | List of all members
LucasWorkflowAssemblies.CalculateDateByBusinessDays Class Reference

This class is used to calculate the date that is X business days from now. More...

Inheritance diagram for LucasWorkflowAssemblies.CalculateDateByBusinessDays:

Protected Member Functions

override void Execute (CodeActivityContext executionContext)
Executes the workflow activity More...

Properties

InArgument< Int16 > | NumBusinessDays [get, set]
[Input("Number of business days")] This input takes the number of business days from today for which the date will be determined. More...
OutArgument< DateTime > | CalculatedDate [get, set]
[Output("Calculated date")] This output is the date calculated from the supplied business days value. More...

Detailed Description

This class is used to calculate the date that is X business days from now.

Member Function Documentation

override void LucasWorkflowAssemblies.CalculateDateByBusinessDays.Execute ( CodeActivityContext executionContext )
protected

Executes the workflow activity

Parameters
executionContext The execution context

Property Documentation

OutArgument<DateTime> LucasWorkflowAssemblies.CalculateDateByBusinessDays.CalculatedDate
getset

[Output("Calculated date")] This output is the date calculated from the supplied business days value.

InArgument<Int16> LucasWorkflowAssemblies.CalculateDateByBusinessDays.NumBusinessDays
getset

[Input("Number of business days")] This input takes the number of business days from today for which the date will be determined.

The documentation for this class was generated from the following file:
  • LucasWorkflowAssemblies/CalculateDateByBusinessDays.cs


Lucas Workflow Demo: LucasWorkflowAssemblies.DoSomething Class Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • DoSomething
Protected Member Functions | Properties | List of all members
LucasWorkflowAssemblies.DoSomething Class Reference

This class does X, Y and Z More...

Inheritance diagram for LucasWorkflowAssemblies.DoSomething:

Protected Member Functions

override void Execute (CodeActivityContext executionContext)
Executes the workflow activity More...

Properties

InArgument< String > | Input1 [get, set]
[Input("Input #1")] This input expects value A. More...
InArgument< String > | Input2 [get, set]
[Input("Input #2")] This input expects value B. More...
OutArgument< String > | Output1 [get, set]
[Output("Output #1")] This output is for X. More...
OutArgument< String > | Output2 [get, set]
[Output("Output #2")] This output is for Y. More...

Detailed Description

This class does X, Y and Z

Member Function Documentation

override void LucasWorkflowAssemblies.DoSomething.Execute ( CodeActivityContext executionContext )
protected

Executes the workflow activity

Parameters
executionContext The execution context

Property Documentation

InArgument<String> LucasWorkflowAssemblies.DoSomething.Input1
getset

[Input("Input #1")] This input expects value A.

InArgument<String> LucasWorkflowAssemblies.DoSomething.Input2
getset

[Input("Input #2")] This input expects value B.

OutArgument<String> LucasWorkflowAssemblies.DoSomething.Output1
getset

[Output("Output #1")] This output is for X.

OutArgument<String> LucasWorkflowAssemblies.DoSomething.Output2
getset

[Output("Output #2")] This output is for Y.

The documentation for this class was generated from the following file:
  • LucasWorkflowAssemblies/DoSomething.cs


Lucas Workflow Demo: LucasWorkflowAssemblies.MyJsonResponse Class Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • MyJsonResponse
Public Member Functions | Properties | List of all members
LucasWorkflowAssemblies.MyJsonResponse Class Reference

This class is used for deserializing the JSON response from the endpoint. More...

Public Member Functions

MyJsonResponse ()
Constructor More...

Properties

string | Output1 [get, set]
This property holds the value of "output1" More...
string | Output2 [get, set]
This property holds the value of "output2" More...

Detailed Description

This class is used for deserializing the JSON response from the endpoint.

Constructor & Destructor Documentation

LucasWorkflowAssemblies.MyJsonResponse.MyJsonResponse ( )

Constructor

Property Documentation

string LucasWorkflowAssemblies.MyJsonResponse.Output1
getset

This property holds the value of "output1"

string LucasWorkflowAssemblies.MyJsonResponse.Output2
getset

This property holds the value of "output2"

The documentation for this class was generated from the following file:
  • LucasWorkflowAssemblies/JsonRequestResponse.cs


Lucas Workflow Demo: LucasWorkflowAssemblies.MyJsonRequest Class Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • MyJsonRequest
Public Member Functions | Properties | List of all members
LucasWorkflowAssemblies.MyJsonRequest Class Reference

This class is used for serializing the JSON request to the endpoint. More...

Public Member Functions

MyJsonRequest ()
Constructor More...

Properties

string | Input1 [get, set]
This property holds the value of "input1" More...
string | Input2 [get, set]
This property holds the value of "input2" More...

Detailed Description

This class is used for serializing the JSON request to the endpoint.

Constructor & Destructor Documentation

LucasWorkflowAssemblies.MyJsonRequest.MyJsonRequest ( )

Constructor

Property Documentation

string LucasWorkflowAssemblies.MyJsonRequest.Input1
getset

This property holds the value of "input1"

string LucasWorkflowAssemblies.MyJsonRequest.Input2
getset

This property holds the value of "input2"

The documentation for this class was generated from the following file:
  • LucasWorkflowAssemblies/JsonRequestResponse.cs


Lucas Workflow Demo: Class Index

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Index
C | D | M
C
D
M
MyJsonResponse (LucasWorkflowAssemblies)
CalculateDateByBusinessDays (LucasWorkflowAssemblies) DoSomething (LucasWorkflowAssemblies) MyJsonRequest (LucasWorkflowAssemblies)
C | D | M


Lucas Workflow Demo: Class Hierarchy

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 12]
o C CodeActivity |
| o C LucasWorkflowAssemblies.CalculateDateByBusinessDays | This class is used to calculate the date that is X business days from now.
| \ C LucasWorkflowAssemblies.DoSomething | This class does X, Y and Z
o C LucasWorkflowAssemblies.MyJsonRequest | This class is used for serializing the JSON request to the endpoint.
\ C LucasWorkflowAssemblies.MyJsonResponse | This class is used for deserializing the JSON response from the endpoint.


Lucas Workflow Demo: Class Members

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Properties
Here is a list of all documented class members with links to the class documentation for each member:
  • CalculatedDate : LucasWorkflowAssemblies.CalculateDateByBusinessDays
  • Execute() : LucasWorkflowAssemblies.CalculateDateByBusinessDays , LucasWorkflowAssemblies.DoSomething
  • Input1 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonRequest
  • Input2 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonRequest
  • MyJsonRequest() : LucasWorkflowAssemblies.MyJsonRequest
  • MyJsonResponse() : LucasWorkflowAssemblies.MyJsonResponse
  • NumBusinessDays : LucasWorkflowAssemblies.CalculateDateByBusinessDays
  • Output1 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonResponse
  • Output2 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonResponse


Lucas Workflow Demo: Class Members - Functions

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Properties
  • Execute() : LucasWorkflowAssemblies.CalculateDateByBusinessDays , LucasWorkflowAssemblies.DoSomething
  • MyJsonRequest() : LucasWorkflowAssemblies.MyJsonRequest
  • MyJsonResponse() : LucasWorkflowAssemblies.MyJsonResponse


Lucas Workflow Demo: Class Members - Properties

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Properties
  • CalculatedDate : LucasWorkflowAssemblies.CalculateDateByBusinessDays
  • Input1 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonRequest
  • Input2 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonRequest
  • NumBusinessDays : LucasWorkflowAssemblies.CalculateDateByBusinessDays
  • Output1 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonResponse
  • Output2 : LucasWorkflowAssemblies.DoSomething , LucasWorkflowAssemblies.MyJsonResponse


Lucas Workflow Demo: Member List

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • CalculateDateByBusinessDays
LucasWorkflowAssemblies.CalculateDateByBusinessDays Member List

This is the complete list of members for LucasWorkflowAssemblies.CalculateDateByBusinessDays, including all inherited members.

CalculatedDate | LucasWorkflowAssemblies.CalculateDateByBusinessDays |
Execute(CodeActivityContext executionContext) | LucasWorkflowAssemblies.CalculateDateByBusinessDays | protected
NumBusinessDays | LucasWorkflowAssemblies.CalculateDateByBusinessDays |


Lucas Workflow Demo: Member List

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • DoSomething
LucasWorkflowAssemblies.DoSomething Member List

This is the complete list of members for LucasWorkflowAssemblies.DoSomething, including all inherited members.

Execute(CodeActivityContext executionContext) | LucasWorkflowAssemblies.DoSomething | protected
Input1 | LucasWorkflowAssemblies.DoSomething |
Input2 | LucasWorkflowAssemblies.DoSomething |
Output1 | LucasWorkflowAssemblies.DoSomething |
Output2 | LucasWorkflowAssemblies.DoSomething |


Lucas Workflow Demo: Member List

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • MyJsonRequest
LucasWorkflowAssemblies.MyJsonRequest Member List

This is the complete list of members for LucasWorkflowAssemblies.MyJsonRequest, including all inherited members.

Input1 | LucasWorkflowAssemblies.MyJsonRequest
Input2 | LucasWorkflowAssemblies.MyJsonRequest
MyJsonRequest() | LucasWorkflowAssemblies.MyJsonRequest


Lucas Workflow Demo: Member List

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LucasWorkflowAssemblies
  • MyJsonResponse
LucasWorkflowAssemblies.MyJsonResponse Member List

This is the complete list of members for LucasWorkflowAssemblies.MyJsonResponse, including all inherited members.

MyJsonResponse() | LucasWorkflowAssemblies.MyJsonResponse
Output1 | LucasWorkflowAssemblies.MyJsonResponse
Output2 | LucasWorkflowAssemblies.MyJsonResponse


Lucas Workflow Demo: LucasWorkflowAssemblies/Properties Directory Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • LucasWorkflowAssemblies
  • Properties
Properties Directory Reference

Files

file AssemblyInfo.cs


Lucas Workflow Demo: LucasWorkflowAssemblies/obj Directory Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • LucasWorkflowAssemblies
  • obj
obj Directory Reference

Directories

directory Debug


Lucas Workflow Demo: LucasWorkflowAssemblies Directory Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • LucasWorkflowAssemblies
LucasWorkflowAssemblies Directory Reference

Directories

directory | obj
directory | Properties

Files

file | CalculateDateByBusinessDays.cs
file | DoSomething.cs
file | JsonRequestResponse.cs


Lucas Workflow Demo: LucasWorkflowAssemblies/obj/Debug Directory Reference

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
  • LucasWorkflowAssemblies
  • obj
  • Debug
Debug Directory Reference

Files

file | TemporaryGeneratedFile_036C0B5B-1481-4323-8D20-8F5ADCB23D92.cs
file | TemporaryGeneratedFile_5937a670-0e60-4077-877b-f7221da3dda1.cs
file | TemporaryGeneratedFile_E7A71F73-0F8D-4B9B-B56E-8E70B10BC5D3.cs


Lucas Workflow Demo: Main Page

Sample project for workflow assemblies
  • Main Page
  • Packages
  • Classes
Lucas Workflow Demo Documentation